Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.1.0 RC3
    • Component/s: UI
    • Labels:
      None

      Description

      In the configuration wizard, when trying to go to the next deployment each time an error occurs. Error log [1]
      But first two policies, partition configuration and autoscaling policies can be deployed with several attempts.
      But it fails to load the "Deployment policy" configuration screen which is next.
      Even when not on configuration wizard it fails to load.

      [1] : TID: [0] [STRATOS] [2014-08-16 09:47:24,657] INFO

      {org.apache.stratos.autoscaler.util.ConfUtil} - Loading configuration..... {org.apache.stratos.autoscaler.util.ConfUtil}

      TID: [0] [STRATOS] [2014-08-16 09:47:24,757] INFO

      {org.apache.stratos.autoscaler.client.cloud.controller.CloudControllerClient} - Validating partition via cloud controller: [id] p2 {org.apache.stratos.autoscaler.client.cloud.controller.CloudControllerClient}

      TID: [0] [STRATOS] [2014-08-16 09:47:32,608] INFO

      {org.apache.stratos.autoscaler.partition.PartitionManager} - Partition is deployed successfully: [id] p2 {org.apache.stratos.autoscaler.partition.PartitionManager}

      TID: [0] [STRATOS] [2014-08-16 09:47:32,618] ERROR

      {org.jaggeryjs.jaggery.core.manager.WebAppManager} - org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (http#17) (/console/controllers/router.jag#119) {org.jaggeryjs.jaggery.core.manager.WebAppManager}

      org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (http#17) (/console/controllers/router.jag#119)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.execute(WebAppManager.java:447)
      at org.jaggeryjs.jaggery.core.JaggeryServlet.doPost(JaggeryServlet.java:29)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:755)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:487)
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:379)
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339)
      at org.jaggeryjs.jaggery.core.JaggeryFilter.doFilter(JaggeryFilter.java:21)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.continueInvocation(CompositeValve.java:178)
      at org.wso2.carbon.tomcat.ext.valves.CarbonTomcatValve$1.invoke(CarbonTomcatValve.java:47)
      at org.wso2.carbon.webapp.mgt.TenantLazyLoaderValve.invoke(TenantLazyLoaderValve.java:56)
      at org.wso2.carbon.tomcat.ext.valves.TomcatValveContainer.invokeValves(TomcatValveContainer.java:47)
      at org.wso2.carbon.tomcat.ext.valves.CompositeValve.invoke(CompositeValve.java:141)
      at org.wso2.carbon.tomcat.ext.valves.CarbonStuckThreadDetectionValve.invoke(CarbonStuckThreadDetectionValve.java:156)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
      at org.wso2.carbon.tomcat.ext.valves.CarbonContextCreatorValve.invoke(CarbonContextCreatorValve.java:52)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1653)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: org.mozilla.javascript.WrappedException: Wrapped org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (http#17) (/console/controllers/router.jag#119)
      at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1754)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:148)
      at org.mozilla.javascript.FunctionObject.call(FunctionObject.java:386)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.jaggeryjs.rhino.console.controllers.c0._c_anonymous_1(/console/controllers/router.jag:119)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:23)
      at org.jaggeryjs.rhino.console.controllers.c0._c_script_0(/console/controllers/router.jag:23)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:394)
      at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3091)
      at org.jaggeryjs.rhino.console.controllers.c0.call(/console/controllers/router.jag)
      at org.jaggeryjs.rhino.console.controllers.c0.exec(/console/controllers/router.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 35 more
      Caused by: org.jaggeryjs.scriptengine.exceptions.ScriptException: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (http#17)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:571)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.exec(RhinoEngine.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.executeScript(WebAppManager.java:273)
      at org.jaggeryjs.jaggery.core.manager.WebAppManager.include(WebAppManager.java:127)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:126)
      ... 47 more
      Caused by: org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (http#17)
      at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1754)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:148)
      at org.mozilla.javascript.FunctionObject.call(FunctionObject.java:386)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.mozilla.javascript.gen.http_1._c_anonymous_2(http:17)
      at org.mozilla.javascript.gen.http_1.call(http)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.mozilla.javascript.gen.http_1._c_anonymous_5(http:221)
      at org.mozilla.javascript.gen.http_1.call(http)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.mozilla.javascript.gen.http_1._c_anonymous_8(http:232)
      at org.mozilla.javascript.gen.http_1.call(http)
      at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:63)
      at org.jaggeryjs.rhino.console.util.c1._c_anonymous_47(/console/util/utility.jag:375)
      at org.jaggeryjs.rhino.console.util.c1.call(/console/util/utility.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.callN(OptRuntime.java:52)
      at org.jaggeryjs.rhino.console.util.c1._c_anonymous_18(/console/util/utility.jag:149)
      at org.jaggeryjs.rhino.console.util.c1.call(/console/util/utility.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:32)
      at org.jaggeryjs.rhino.console.controllers.c3._c_anonymous_1(/console/controllers/wizardSubmit.jag:38)
      at org.jaggeryjs.rhino.console.controllers.c3.call(/console/controllers/wizardSubmit.jag)
      at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:23)
      at org.jaggeryjs.rhino.console.controllers.c3._c_script_0(/console/controllers/wizardSubmit.jag:22)
      at org.jaggeryjs.rhino.console.controllers.c3.call(/console/controllers/wizardSubmit.jag)
      at org.jaggeryjs.rhino.console.controllers.c3.exec(/console/controllers/wizardSubmit.jag)
      at org.jaggeryjs.scriptengine.engine.RhinoEngine.execScript(RhinoEngine.java:567)
      ... 55 more
      Caused by: java.lang.NullPointerException
      at org.jaggeryjs.scriptengine.util.HostObjectUtil.invalidArgsError(HostObjectUtil.java:41)
      at org.jaggeryjs.scriptengine.engine.RhinoTopLevel.parse(RhinoTopLevel.java:48)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:126)
      ... 79 more

        Activity

        rajkumarr Rajkumar Rajaratnam added a comment -

        Hi,

        Attached the patch here.

        ravihansa@wso2.com Akila added a comment -

        Fixed in 4849418169266bc8e2ad4ced4828f2709556e77a

        On Mon, Sep 1, 2014 at 11:10 AM, Rajkumar Rajaratnam (JIRA)


        Akila Ravihansa Perera
        Software Engineer, WSO2
        Committer & PMC Member, Apache Stratos

        Blog: http://ravihansa3000.blogspot.com

        ravihansa@wso2.com Akila added a comment -

        Fixed in 4849418169266bc8e2ad4ced4828f2709556e77a

        On Mon, Sep 1, 2014 at 11:10 AM, Rajkumar Rajaratnam (JIRA)


        Akila Ravihansa Perera
        Software Engineer, WSO2
        Committer & PMC Member, Apache Stratos

        Blog: http://ravihansa3000.blogspot.com

        githubbot ASF GitHub Bot added a comment -

        Github user R-Rajkumar closed the pull request at:

        https://github.com/apache/stratos/pull/19


          People

          • Assignee:
            Unassigned
            Reporter:
            asiriwork@gmail.com Asiri Liyana Arachchi
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development