Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-62

jclouds Authentication Error in Cloud Controller

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      It looks like with the recent jclouds upgrade in the Cloud Controller, the IaaS authentication call fails with the following error:

      Scenario:
      1. Build Cloud Controller from source.
      2. Setup an OpenStack instance.
      3. Configure Cloud Controller IaaS settings and cartridges to connect to OpenStack instance created.
      4. Start Cloud Controller and tail the log.

      Please note that this error is raised when deploying the cartridge definitions. See the attached trace file for more information.

      Error:
      Caused by: org.jclouds.http.HttpResponseException: command: POST http://192.168.16.252:5000/tokens HTTP/1.1 failed with response: HTTP/1.1 404 Not Found; content: [{"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}]
      at org.jclouds.openstack.nova.v2_0.handlers.NovaErrorHandler.handleError(NovaErrorHandler.java:81)
      ... 70 more
      [2013-08-23 12:38:11,574] ERROR

      {org.apache.zookeeper.server.NIOServerCnxnFactory}

      - Thread Thread[pool-6-thread-1,5,main] died
      org.apache.stratos.cloud.controller.exception.CloudControllerException: org.jclouds.rest.ResourceNotFoundException: {"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}
      at org.apache.stratos.cloud.controller.deployers.CartridgeDeployer.handleException(CartridgeDeployer.java:153)
      at org.apache.stratos.cloud.controller.deployers.CartridgeDeployer.access$000(CartridgeDeployer.java:45)
      at org.apache.stratos.cloud.controller.deployers.CartridgeDeployer$JcloudsObjectBuilder.run(CartridgeDeployer.java:181)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:662)

      1. cc-log.txt
        53 kB
        Imesh Gunaratne

        Activity

        chrishantha Isuru Perera added a comment -

        This is a problem with jclouds endpoint API URL. Please use the keystone URL as shown in OpenStack API page (Horizon UI -> Settings)

        In your case, change jclouds.endpoint property from "http://192.168.16.252:5000/" to "http://192.168.16.252:5000/v2.0" in cloud controller xml.

        I tested this and it works!

        chrishantha Isuru Perera added a comment -

        Imesh,

        Please test other scenarios with OpenStack + latest jclouds and let me know.

        Thanks!

        chrishantha Isuru Perera added a comment -

        Resolving this since jclouds errors were fixed.


          People

          • Assignee:
            chrishantha Isuru Perera
            Reporter:
            imesh Imesh Gunaratne
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development