Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-29

Stratos Controller isEmailValidated() Service Method Fail

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      It looks like the email validation logic in Tenant home page fails due to the following error:

      Scenario:
      1. Start Apache Stratos Controller (SC).
      2. Login to the web UI using http://hostname:port/carbon
      3. Create a new Tenant.
      4. Logout from SC web UI.
      5. Login again using the Tenant user credentials created.
      6. See the trace log on the terminal.

      [2013-08-05 08:52:07,739] ERROR

      {org.apache.axis2.rpc.receivers.RPCMessageReceiver}

      - Exception occurred while trying to invoke service method isEmailValidated
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.axis2.rpc.receivers.RPCUtil.invokeServiceClass(RPCUtil.java:212)
      at org.apache.axis2.rpc.receivers.RPCMessageReceiver.invokeBusinessLogic(RPCMessageReceiver.java:117)
      at org.apache.axis2.receivers.AbstractInOutMessageReceiver.invokeBusinessLogic(AbstractInOutMessageReceiver.java:40)
      at org.apache.axis2.receivers.AbstractMessageReceiver.receive(AbstractMessageReceiver.java:110)
      at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:180)
      at org.apache.axis2.transport.local.LocalTransportReceiver.processMessage(LocalTransportReceiver.java:169)
      at org.apache.axis2.transport.local.LocalTransportReceiver.processMessage(LocalTransportReceiver.java:82)
      at org.wso2.carbon.core.transports.local.CarbonLocalTransportSender.finalizeSendWithToAddress(CarbonLocalTransportSender.java:45)
      at org.apache.axis2.transport.local.LocalTransportSender.invoke(LocalTransportSender.java:77)
      at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:442)
      at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:398)
      at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:224)
      at org.apache.axis2.client.OperationClient.execute(OperationClient.java:149)
      at org.apache.stratos.account.mgt.stub.services.AccountMgtServiceStub.isEmailValidated(AccountMgtServiceStub.java:2049)
      at org.apache.stratos.account.mgt.ui.clients.AccountMgtClient.isEmailValidated(AccountMgtClient.java:171)
      at org.apache.jsp.tenant_002ddashboard.index_jsp._jspService(org.apache.jsp.tenant_002ddashboard.index_jsp:149)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)
      ...

      Caused by: java.lang.NullPointerException
      at org.apache.stratos.account.mgt.util.Util.getTenantManager(Util.java:96)
      at org.apache.stratos.account.mgt.services.AccountMgtService.getContact(AccountMgtService.java:121)
      at org.apache.stratos.account.mgt.services.AccountMgtService.isEmailValidated(AccountMgtService.java:403)

      1. sc-log.txt
        81 kB
        Imesh Gunaratne
      2. 0001-Fixed-the-account-management-page-loading-error.patch
        4 kB
        Manula Chathurika Thantriwatte

        Activity

        manulac Manula Chathurika Thantriwatte added a comment -

        Fixed in commit 0eba94f8763ea77e88f46255f48fe5d8dc181547


          People

          • Assignee:
            manulac Manula Chathurika Thantriwatte
            Reporter:
            imesh Imesh Gunaratne
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development