Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3617

Remove deprecation from PlainSaslTransportPlugin

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: storm-core
    • Labels:
      None

      Description

      Whenever PlainSaslTransportPlugin is used, it logs an error about it being insecure. The class itself is also marked as deprecated - which is fair, as it is doesn't provide any security at all.

      However, we are running in situations where we don't _need _security, and we don't want the extra fragility introduced by adding in security. We're perfectly ok with using an insecure transport, and we're using PlainSaslTransport over the default because we don't want to configure the buffer size of the default transport.

      So please could you remove the deprecation marker from PlainSaslTransport, and downgrade the ERROR message to an INFO. We don't need security in our situations, and so running a default basic transport is exactly what we want to do.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              thecoop1984 Simon Cooper

              Dates

              • Created:
                Updated:

                Issue deployment