Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3616

If running upload credentials and no autocreds are found, we should have an option to fail

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0
    • Component/s: None

      Description

      User tried to upload credentials on a box with a bad setup. Because the command passed, it was assumed to be ok. Then the topology certs timed out and dev got involved.

      If the command had just failed, we would not have gotten involved at all.

      Existing output:

      1809 [main] INFO  b.s.s.a.AuthUtils - Got AutoCreds []
      1810 [main] WARN  b.s.StormSubmitter - No credentials were found to push to edgestorm
      1812 [main] INFO  b.s.c.upload-credentials - Uploaded new creds to topology: edgestorm

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                li530 Rui Li
                Reporter:
                li530 Rui Li
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 3h 40m
                  3h 40m