Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3386

Set minimum Maven version for build to 3.5.0

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: None

      Description

      Alexandre Vermeerbergen found that the build doesn't work on Maven 3.3.9. This is likely because some plugin requires Maven version 3.5.0, but they forgot to specify that requirement in their POM.

      We might as well bump our Maven version check to 3.5.0.

        Attachments

          Activity

            People

            • Assignee:
              srdo Stig Rohde Døssing
              Reporter:
              srdo Stig Rohde Døssing

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 50m
                50m

                  Issue deployment