Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-331

storm-kafka: bump Kafka version dependency to 0.8.1.1

    XMLWordPrintableJSON

    Details

    • Type: Dependency upgrade
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.9.2-incubating
    • Fix Version/s: 0.9.2-incubating
    • Component/s: storm-kafka
    • Labels:
      None

      Description

      The Kafka project has recently published the hot fix release Kafka 0.8.1.1, which addresses a number of bugs that, essentially, forced a lot of users to revert from 0.8.1 to 0.8.0.

      storm-kafka still depends on the buggy 0.8.1 Kafka release, and thus should be updated to use 0.8.1.1 instead.

      I performed basic functional testing of Kafka<->Storm interoperability using Storm 0.9.1 and Kafka 0.8.1.1, and the integration looks ok (I would have been surprised if it didn't). Hence I'd say it's safe to bump the Kafka version of 0.8.1.1.

        Attachments

          Activity

            People

            • Assignee:
              miguno Michael G. Noll
              Reporter:
              miguno Michael G. Noll
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: