Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3269

storm-client and storm-server indirectly depend on storm-core

    Details

      Description

      When trying to get the version information for nimbus it looks for storm-core, which requires the storm-core class to be on the classpath.  We need to fix this, because VersionInfo is in storm-client so it is possible for someone who uses it from storm-client to load the wrong thing.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                revans2 Robert Joseph Evans
                Reporter:
                revans2 Robert Joseph Evans
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m