Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3015

storm-kafka-client-examples should not depend on the Kafka server jar

    XMLWordPrintableJSON

    Details

      Description

      The kafka_2.10 dependency is unnecessary, and adds a little more hassle than necessary to switching the Kafka client version. E.g. To switch to Kafka 1.1.0, you have to also replace kafka_2.10 with kafka_2.11

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                srdo Stig Rohde Døssing
                Reporter:
                srdo Stig Rohde Døssing
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m