Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-2698

Upgrade to newest Mockito and Hamcrest versions

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0, 1.2.0
    • Fix Version/s: 2.0.0
    • Component/s: None

      Description

      We are currently depending on Mockito 1.9.5, which is from 2012. I think we should upgrade to the latest version, since some APIs have become a little nicer to work with.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Srdo Stig Rohde Døssing
                Reporter:
                Srdo Stig Rohde Døssing
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 40m
                  40m