Sqoop
  1. Sqoop
  2. SQOOP-488

Parameter for extended verbose is not working due to migrated code to different module

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0-incubating, 1.4.1-incubating
    • Fix Version/s: 1.4.2
    • Component/s: None
    • Labels:
      None

      Description

      Parameter --verbose is not working as expected on 1.4.x. This is caused by code move to module org.apache.sqoop from com.cloudera.apache without fixing verbose handling code.

      1. SQOOP-488.patch
        0.7 kB
        Jarek Jarcec Cecho
      2. SQOOP-488.patch
        0.7 kB
        Jarek Jarcec Cecho

        Issue Links

          Activity

          Jarek Jarcec Cecho created issue -
          Jarek Jarcec Cecho made changes -
          Field Original Value New Value
          Attachment SQOOP-488.patch [ 12528309 ]
          Jarek Jarcec Cecho made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Jarek Jarcec Cecho made changes -
          Attachment SQOOP-488.patch [ 12528310 ]
          Jarek Jarcec Cecho added a comment -

          Attached patch do have granted Apache license even though that Apache icon is not visible (at least for me).

          Jarek Jarcec Cecho made changes -
          Link This issue blocks SQOOP-487 [ SQOOP-487 ]
          Cheolsoo Park added a comment -

          +1.

          I also noticed this issue while working on other jiras.

          Kathleen Ting added a comment -

          Patch committed. Thanks Jarcec!

          Kathleen Ting made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          Integrated in Sqoop-ant-jdk-1.6 #115 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6/115/)
          SQOOP-488. Parameter for extended verbose is not working due to migrated code to different module
          (Jarek Jarcec Cecho via Kathleen Ting) (Revision 1343147)

          Result = SUCCESS
          kathleen :
          Files :

          • /sqoop/trunk/src/java/org/apache/sqoop/tool/BaseSqoopTool.java
          Cheolsoo Park made changes -
          Attachment SQOOP-488-2.patch [ 12530147 ]
          Cheolsoo Park made changes -
          Attachment SQOOP-488-2.patch [ 12530147 ]
          Cheolsoo Park made changes -
          Comment [ While working on another jira, I've noticed that a style check error is introduced into the trunk.

          Please find the attached patch: SQOOP-488-2.patch. ]
          Cheolsoo Park made changes -
          Link This issue is related to SQOOP-490 [ SQOOP-490 ]
          Gavin made changes -
          Link This issue blocks SQOOP-487 [ SQOOP-487 ]
          Gavin made changes -
          Link This issue is depended upon by SQOOP-487 [ SQOOP-487 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          3m 21s 1 Jarek Jarcec Cecho 20/May/12 09:30
          Patch Available Patch Available Resolved Resolved
          7d 22h 12m 1 Kathleen Ting 28/May/12 07:42

            People

            • Assignee:
              Jarek Jarcec Cecho
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development