Sqoop
  1. Sqoop
  2. SQOOP-361

[Docs] $CONDITIONS must be escaped to not allow shells to replace it.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.4.0-incubating
    • Fix Version/s: 1.4.0-incubating
    • Component/s: docs
    • Labels:

      Description

      In section 7.2.3 of the Sqoop User Guide, the examples can mislead people.

      The examples must carry escapes to the $ symbol, like \$ in order for it to directly work, and also carry a note on why that is required – to not allow shells to substitute it.

      1. SqoopUserGuide.html
        233 kB
        Harsh J
      2. SQOOP-361.patch
        0.7 kB
        Harsh J

        Activity

        Bilung Lee added a comment -

        Yes, patch committed. Thanks, Harsh!

        Harsh J added a comment -

        Resolving. This was committed. Thanks Bilung!

        Hudson added a comment -

        Integrated in Sqoop-jdk-1.6 #39 (See https://builds.apache.org/job/Sqoop-jdk-1.6/39/)
        SQOOP-361 [Docs] $CONDITIONS must be escaped to not allow shells to replace it.

        (Harsh J via Bilung Lee)

        blee : http://svn.apache.org/viewvc/?view=rev&rev=1185449
        Files :

        • /incubator/sqoop/trunk/src/docs/user/import.txt
        Bilung Lee added a comment -

        Look good to me. Thanks!

        Harsh J added a comment -

        Tested with make userguide and the rendered HTML (attached) appears to look as intended.

        Harsh J added a comment -

        Patch that adds in a note. The existing example query is single-quoted, so this patch just adds a note in case someone would attempt to use double quotes in their query string in their shell.

        Harsh J added a comment -

        Attaching a patch shortly.


          People

          • Assignee:
            Harsh J
            Reporter:
            Harsh J
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development