Sqoop
  1. Sqoop
  2. SQOOP-1131

New test added in SQOOP-1121 is using unsupported API in Hadoop 100

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: None
    • Labels:
      None

      Description

      I've added test in SQOOP-1121 that is using JobClient API method that is not present in Hadoop 1.x line. My sincere apologies for that!

      1. bugSQOOP-1131.patch
        0.7 kB
        Jarek Jarcec Cecho

        Issue Links

          Activity

          ASF subversion and git services added a comment -

          Commit 74ebecb7ce61dbeb98f5b6541992afb69883b75d in branch refs/heads/sqoop2 from Hari Shreedharan
          [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=74ebecb ]

          SQOOP-1131. New test added in SQOOP-1121 is using unsupported API in Hadoop 100

          (Jarek Jarcec Cecho via Hari Shreedharan)

          Hari Shreedharan added a comment -

          Patch committed, thanks Jarcec!

          Hudson added a comment -

          Integrated in Sqoop2-hadoop200 #459 (See https://builds.apache.org/job/Sqoop2-hadoop200/459/)
          SQOOP-1131. New test added in SQOOP-1121 is using unsupported API in Hadoop 100 (Revision 74ebecb7ce61dbeb98f5b6541992afb69883b75d)

          Result = FAILURE
          hshreedharan : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=74ebecb7ce61dbeb98f5b6541992afb69883b75d
          Files :

          • execution/mapreduce/src/test/java/org/apache/sqoop/job/mr/TestConfigurationUtils.java
          Hudson added a comment -

          Integrated in Sqoop2-hadoop100 #481 (See https://builds.apache.org/job/Sqoop2-hadoop100/481/)
          SQOOP-1131. New test added in SQOOP-1121 is using unsupported API in Hadoop 100 (Revision 74ebecb7ce61dbeb98f5b6541992afb69883b75d)

          Result = SUCCESS
          hshreedharan : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=74ebecb7ce61dbeb98f5b6541992afb69883b75d
          Files :

          • execution/mapreduce/src/test/java/org/apache/sqoop/job/mr/TestConfigurationUtils.java
          Jarek Jarcec Cecho added a comment -

          This time the failure in profile 200 is caused by jenkins memory issues (return code 143).


            People

            • Assignee:
              Jarek Jarcec Cecho
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development