Sqoop
  1. Sqoop
  2. SQOOP-1082

Implement pre-commit testing with Jenkins

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: None
    • Labels:
      None

      Description

      Hadoop/Flume/Oozie all have pre-commit testing of patches. It would be great to see the same done for Sqoop also

      1. bugSQOOP-1082.patch
        14 kB
        Jarek Jarcec Cecho

        Issue Links

          Activity

          Jarek Jarcec Cecho added a comment -

          I know that Brock Noland was doing something similar for Flume, so I'll get in touch with him to see how this can be achieved.

          Venkat Ranganathan added a comment -

          FLUME-1787 has the Flume implementation information

          Jarek Jarcec Cecho added a comment -

          I've uploaded patch that needs to be committed to sqoop2 branch before additional steps can be taken.

          Brock Noland added a comment -

          Hey you are looking for FLUME-1787. Although the code has been committed I have not had the time to setup the pre-commit stuff.

          ASF subversion and git services added a comment -

          Commit fe54d473afbfd9982942beb96b582c5b9faab549 in branch refs/heads/sqoop2 from Kathleen Ting
          [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=fe54d47 ]

          SQOOP-1082: Implement pre-commit testing with Jenkins

          (Jarek Jarcec Cecho via Kate Ting)

          Kathleen Ting added a comment -

          Thanks Jarcec for the contribution.

          Hudson added a comment -

          Integrated in Sqoop2-hadoop200 #417 (See https://builds.apache.org/job/Sqoop2-hadoop200/417/)
          SQOOP-1082: Implement pre-commit testing with Jenkins (Revision fe54d473afbfd9982942beb96b582c5b9faab549)

          Result = FAILURE
          kathleen : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=fe54d473afbfd9982942beb96b582c5b9faab549
          Files :

          • dev-support/test-patch.py
          • .gitignore
          • pom.xml
          Hudson added a comment -

          Integrated in Sqoop2-hadoop100 #416 (See https://builds.apache.org/job/Sqoop2-hadoop100/416/)
          SQOOP-1082: Implement pre-commit testing with Jenkins (Revision fe54d473afbfd9982942beb96b582c5b9faab549)

          Result = FAILURE
          kathleen : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=fe54d473afbfd9982942beb96b582c5b9faab549
          Files :

          • .gitignore
          • dev-support/test-patch.py
          • pom.xml
          Venkat Ranganathan added a comment -

          Thanks for implementing this

          Jarek Jarcec Cecho added a comment -

          The Jenkins failure is caused by "No space left on device".


            People

            • Assignee:
              Jarek Jarcec Cecho
              Reporter:
              Venkat Ranganathan
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development