Sqoop
  1. Sqoop
  2. SQOOP-1028

Remove poll timeout parameter from Sqoop shell synchronous submission

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: None
    • Labels:
      None

      Description

      I think that the poll timeout is more suitable to be shell property like verbose rather then function argument.

      1. SQOOP-1028.1.patch
        7 kB
        Mengwei Ding
      2. SQOOP-1028.2.patch
        9 kB
        Mengwei Ding
      3. SQOOP-1028.3.patch
        9 kB
        Mengwei Ding

        Issue Links

          Activity

          Jarek Jarcec Cecho added a comment -

          Setting status to "Patch available" to show this ticket in our review queue.

          ASF subversion and git services added a comment -

          Commit 8122d4ca937cd8258f4e775dd40d3d52259c6e53 in branch refs/heads/sqoop2 from Jarek Jarcec Cecho
          [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=8122d4c ]

          SQOOP-1028: Remove poll timeout parameter from Sqoop shell synchronous submission

          (Mengwei Ding via Jarek Jarcec Cecho)

          Jarek Jarcec Cecho added a comment -
          Hudson added a comment -

          Integrated in Sqoop2-hadoop100 #295 (See https://builds.apache.org/job/Sqoop2-hadoop100/295/)
          SQOOP-1028: Remove poll timeout parameter from Sqoop shell synchronous submission (Revision 8122d4ca937cd8258f4e775dd40d3d52259c6e53)

          Result = FAILURE
          jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=8122d4ca937cd8258f4e775dd40d3d52259c6e53
          Files :

          • client/src/main/java/org/apache/sqoop/client/shell/SubmissionStartFunction.java
          • docs/src/site/sphinx/CommandLineClient.rst
          • client/src/main/java/org/apache/sqoop/client/shell/ShellEnvironment.java
          • client/src/main/java/org/apache/sqoop/client/core/Constants.java
          • client/src/main/java/org/apache/sqoop/client/shell/ShowOptionFunction.java
          • client/src/main/resources/client-resource.properties
          • client/src/main/java/org/apache/sqoop/client/shell/SetOptionFunction.java
          Hudson added a comment -

          Integrated in Sqoop2-hadoop200 #300 (See https://builds.apache.org/job/Sqoop2-hadoop200/300/)
          SQOOP-1028: Remove poll timeout parameter from Sqoop shell synchronous submission (Revision 8122d4ca937cd8258f4e775dd40d3d52259c6e53)

          Result = SUCCESS
          jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=8122d4ca937cd8258f4e775dd40d3d52259c6e53
          Files :

          • client/src/main/java/org/apache/sqoop/client/shell/SubmissionStartFunction.java
          • client/src/main/resources/client-resource.properties
          • client/src/main/java/org/apache/sqoop/client/shell/ShellEnvironment.java
          • docs/src/site/sphinx/CommandLineClient.rst
          • client/src/main/java/org/apache/sqoop/client/shell/SetOptionFunction.java
          • client/src/main/java/org/apache/sqoop/client/shell/ShowOptionFunction.java
          • client/src/main/java/org/apache/sqoop/client/core/Constants.java
          Jarek Jarcec Cecho added a comment -

          The failure is caused by Jenkins memory issues.


            People

            • Assignee:
              Mengwei Ding
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development