Uploaded image for project: 'Spot'
  1. Spot
  2. SPOT-21

[UI] IPlocation info display wrong on UI "Suspicious Flow" pane

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Environment:
      Spot code running on MapR.

      Description

      I made an iploc.csv file and ran it through OA. when I look at the Geo (hover) information on the UI, I seem to be getting the contents of the "State" and "City" rather than "Country" and "City".

      Format base on this from docs:
      0. IP Range start (long)
      1. IP Range end (long)
      2. Country code (string)
      3. Country (String)
      4. State (string)
      5. City (string)
      6. Latitude (float)
      7. Longitude (float)
      8. Owner or Register (string)
      9. Domain name (string)

      Sample from my file:

      1589880320,1589880446,GB,United Kingdom,England,Upton upon Severn,52.0667,-2.2167,,

      1677755520,1677755646,US,United States,Massachusetts,Upton,42.1761,-71.6000,,

      2194079744,2194087934,US,United States,New York,Upton,40.8695,-72.8868,,

      I later added double quotes on all fields at suggestion of developer, which made no change.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ledagl Leda G. Lima
                Reporter:
                thealy Terry Healy
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4h
                  4h
                  Remaining:
                  Remaining Estimate - 4h
                  4h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified