Planned changes, primarily to allow us more flexibility in the future:
- Rename "tau_0" to "tau0"
- Mark LDAOptimizer trait sealed and DeveloperApi.
- Mark LDAOptimizer subclasses as final.
- Mark setOptimizer (the one taking an LDAOptimizer) and getOptimizer as DeveloperApi since we may need to change them in the future