Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-45314 Drop Scala 2.12 and make Scala 2.13 by default
  3. SPARK-45688

Clean up the deprecated API usage related to `MapOps`

    XMLWordPrintableJSON

Details

    Description

      • method - in trait MapOps is deprecated (since 2.13.0)
      • method – in trait MapOps is deprecated (since 2.13.0)
      • method + in trait MapOps is deprecated (since 2.13.0)

       

      [warn] /Users/yangjie01/SourceCode/git/spark-mine-sbt/core/src/main/scala/org/apache/spark/deploy/worker/CommandUtils.scala:84:27: method + in trait MapOps is deprecated (since 2.13.0): Consider requiring an immutable Map or fall back to Map.concat.
      [warn] Applicable -Wconf / @nowarn filters for this warning: msg=<part of the message>, cat=deprecation, site=org.apache.spark.deploy.worker.CommandUtils.buildLocalCommand.newEnvironment, origin=scala.collection.MapOps.+, version=2.13.0
      [warn]       command.environment + ((libraryPathName, libraryPaths.mkString(File.pathSeparator)))
      [warn]                           ^
      [warn] /Users/yangjie01/SourceCode/git/spark-mine-sbt/core/src/main/scala/org/apache/spark/deploy/worker/CommandUtils.scala:91:22: method + in trait MapOps is deprecated (since 2.13.0): Consider requiring an immutable Map or fall back to Map.concat.
      [warn] Applicable -Wconf / @nowarn filters for this warning: msg=<part of the message>, cat=deprecation, site=org.apache.spark.deploy.worker.CommandUtils.buildLocalCommand, origin=scala.collection.MapOps.+, version=2.13.0
      [warn]       newEnvironment += (SecurityManager.ENV_AUTH_SECRET -> securityMgr.getSecretKey())
      [warn]                      ^ 

      Attachments

        Issue Links

          Activity

            People

              panbingkun BingKun Pan
              LuciferYang Yang Jie
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: