I'm debugging a parquet issue and reading spark code as references. Happened to find a misleading comment which remains in the latest version as well.
the comment above is misleading since Hive always uses "array_element" as the name.
Furthermore, the parquet-hive module has been removed from the parquet-mr project https://issues.apache.org/jira/browse/PARQUET-1676
I suggest removing this piece of comment and will submit a PR later.