Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-35171

Declare the markdown package as a dependency of the SparkR package

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.1.0
    • 3.1.2, 3.2.0
    • R
    • None

    Description

      If we didn't install pandoc locally, the make-distribution package will fail with the following message:

      — re-building ‘sparkr-vignettes.Rmd’ using rmarkdown
      Warning in engine$weave(file, quiet = quiet, encoding = enc) :
      Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
      Error: processing vignette 'sparkr-vignettes.Rmd' failed with diagnostics:
      The 'markdown' package should be declared as a dependency of the 'SparkR' package (e.g., in the 'Suggests' field of DESCRIPTION), because the latter contains vignette(s) built with the 'markdown' package. Please see https://github.com/yihui/knitr/issues/1864 for more information.
      — failed re-building ‘sparkr-vignettes.Rmd’

      Attachments

        Activity

          People

            XuanYuan Yuanjian Li
            XuanYuan Yuanjian Li
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: