Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-28041

Increase the minimum pandas version to 0.23.2

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: PySpark
    • Labels:
      None

      Description

      Currently, the minimum supported Pandas version is 0.19.2. We bumped up testing in the Jenkins env to 0.23.2 and since 0.19.2 was released nearly 3 years ago, it is not always compatible with other Python libraries. Increasing the version to 0.23.2 will also allow some workarounds to be removed and make maintenance easier.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bryanc Bryan Cutler
                Reporter:
                bryanc Bryan Cutler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: