Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-26014

Deprecate R < 3.4 support

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: SparkR
    • Labels:
    • Target Version/s:
    • Docs Text:
      Versions of R before 3.4 are deprecated in Spark 3.0.0.

      Description

      See http://apache-spark-developers-list.1001551.n3.nabble.com/discuss-SparkR-CRAN-feasibility-check-server-problem-td25605.html

      R version. 3.1.x is too old. It's released 4.5 years ago.
      R 3.4.0 is released 1.5 years ago. Considering the timing for Spark 3.0, deprecating lower versions, bumping up R to 3.4 might be reasonable option.

      It should be good to deprecate and drop < R 3.4 support.

      If we think about the practice, nothing particular is required within R codes as far as I can tell.
      We will just upgrade Jenkins's R version to 3.4, which mean we're not going to test 3.1 R version (but instead we will test 3.4).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                hyukjin.kwon Hyukjin Kwon
                Reporter:
                hyukjin.kwon Hyukjin Kwon
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: