The current option name `wholeFile` is misleading for CSV. Currently, it is not representing a record per file. Actually, one file could have multiple records. Thus, we should rename it. Now, the proposal is `multiLine`.
To make it consistent, we need to rename the same option for JSON and fix the issue in another JIRA.