Solr
  1. Solr
  2. SOLR-4584

Request proxy mechanism not work if rows param is equal to zero

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2
    • Fix Version/s: 4.3, 6.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux Centos 6, Tomcat 7

      Description

      If I try to do a request like:

      http://192.168.20.47:8983/solr/ST-3A856BBCA3_12/select?q=*:*&rows=0

      The request fail. The solr UI logging has this error:

       
      null:org.apache.solr.common.SolrException: Error trying to proxy request for url: http://192.168.20.47:8983/solr/ST-3A856BBCA3_12/select
      

       

      Chrome says:

      This webpage is not available
      The webpage at http://192.168.20.47:8983/solr/ST-038412DCC2_0612/query?q=id:*&rows=0 might be temporarily down or it may have moved permanently to a new web address.
      Error 321 (net::ERR_INVALID_CHUNKED_ENCODING): Unknown error.

      If the param rows is set to rows=4 or superior the query return data as expected.

      1. Screen Shot 00.png
        53 kB
        Yago Riveiro
      2. Screen Shot 01.png
        128 kB
        Yago Riveiro
      3. Screen Shot 02.png
        131 kB
        Yago Riveiro
      4. Screen Shot 03.png
        50 kB
        Yago Riveiro
      5. select
        0.1 kB
        Yago Riveiro

        Issue Links

          Activity

          Mark Miller added a comment -

          Hmm, I can't duplicate this on trunk. I'll try the 4.2 branch in a bit.

          Yago Riveiro added a comment - - edited

          I created the core using core API:

          curl http://192.168.20.48/solr/admin/cores?action=CREATE&name=ST-038412DCC2_0612&collection=ST-038412DCC2_0612&shard=00&collection.configName=statisticsBucket-regular.
          
            "ST-038412DCC2_0612":{
              "shards":{"00":{
                  "state":"active",
                  "replicas":{"192.168.20.48:8983_solr_ST-038412DCC2_0612":{
                      "shard":"00",
                      "state":"active",
                      "core":"ST-038412DCC2_0612",
                      "collection":"ST-038412DCC2_0612",
                      "node_name":"192.168.20.48:8983_solr",
                      "base_url":"http://192.168.20.48:8983/solr",
                      "leader":"true"}}}},
              "router":"implicit"},
          

          The solr version is:

          solr-spec 4.2.0.2013.03.06.22.32.13
          solr-impl 4.2.0 1453694 - rmuir - 2013-03-06 22:32:13
          
          Yago Riveiro added a comment -

          in these screenshots describes the behavior of the bug

          00 - First request to node that content the core, works fine.

          01 - Request data in a node that not content the core, not work.

          02 - Same node, rows=3, not work.

          03 - same node, rows=4, works as expected.

          Mark Miller added a comment -

          That's what I did when I tried to recreate this (though I used rows=0 as you originally reported) - it proxied the requests fine for me.

          Yago Riveiro added a comment -

          :S, I tried again and doesn't work. I changed the wt to javabin for the browse doesn't interpret the response and the response is truncated, you can see it in file "select" that I'm attach.

          Mark Miller added a comment -

          Have you tried it with the jetty we ship, or just tomcat?

          Yago Riveiro added a comment -

          Only with Tomcat 7.0.35

          Uwe Schindler added a comment -

          Did you check with latest Tomcat 7.0? The used one 7.0..35 is no longer the actual one and there were some fixes regard chunked request encoding since 7.0.35, see: http://tomcat.apache.org/tomcat-7.0-doc/changelog.html

          It would be good if you could try to reproduce this with the Jetty webserver shipped together with Solr.

          Yago Riveiro added a comment -

          Tomorrow I will try to upgrade to the last version of tomcat. I will pull some data from production and set up a SolrCluster with Jetty on my local environment to try replicate it.

          Uwe Schindler added a comment -

          As said before, if you can reporduce with latest Tomcat, please also use the included Jetty webserver ("java -jar start.jar" inside example folder) to run Solr. If this fixes the bug, there is a chunked encoding issue in Tomcat that may need further investigation.

          Yago Riveiro added a comment -

          I upgrade my cluster to the last tomcat and solr release.The upgrade not solve the problem.
          I created 2 solr instances running with jetty and the problem doesn't reproduces.

          Mark Miller added a comment - - edited

          Looks like Po got to the bottom of this in SOLR-4716 - since he has a patch, I'll make this a duplicate of that and finish up the fix in SOLR-4210.

          Commit Tag Bot added a comment -

          [trunk commit] markrmiller
          http://svn.apache.org/viewvc?view=revision&revision=1469672

          SOLR-4716,SOLR-4584: SolrCloud request proxying does not work on Tomcat and perhaps other non Jetty containers.

          Commit Tag Bot added a comment -

          [branch_4x commit] markrmiller
          http://svn.apache.org/viewvc?view=revision&revision=1469676

          SOLR-4716,SOLR-4584: SolrCloud request proxying does not work on Tomcat and perhaps other non Jetty containers.

          Commit Tag Bot added a comment -

          [lucene_solr_4_3 commit] markrmiller
          http://svn.apache.org/viewvc?view=revision&revision=1469677

          SOLR-4716,SOLR-4584: SolrCloud request proxying does not work on Tomcat and perhaps other non Jetty containers.

          Uwe Schindler added a comment -

          Closed after release.

          Anshum Gupta added a comment -

          This isn't a 6.0 fix. Seems like something is off here.

          Steve Rowe added a comment -

          Anshum Gupta, this issue got caught up in Hoss'ss master->6.0 fixVersion change. I think we can just remove 6.0?


            People

            • Assignee:
              Mark Miller
              Reporter:
              Yago Riveiro
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development