Solr
  1. Solr
  2. SOLR-4467

Ephemeral directory implementations may not recover correctly because the code to clear the tlog files on startup is off.

    Details

    • Type: Bug Bug
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.9, 5.0
    • Component/s: None
    • Labels:
      None

      Activity

      Mark Miller created issue -
      Commit Tag Bot added a comment -

      [trunk commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1446929

      SOLR-4467: CHANGES entry

      Commit Tag Bot added a comment -

      [trunk commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1446928

      SOLR-4467: Ephemeral directory implementations may not recover correctly because the code to clear the tlog files on startup is off.

      Mark Miller made changes -
      Field Original Value New Value
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Commit Tag Bot added a comment -

      [branch_4x commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1446943

      SOLR-4467: CHANGES entry

      Commit Tag Bot added a comment -

      [branch_4x commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1446942

      SOLR-4467: Ephemeral directory implementations may not recover correctly because the code to clear the tlog files on startup is off.

      Mark Miller added a comment -

      There is a problem with a test on windows because a tlog file cannot be removed.

      Mark Miller made changes -
      Resolution Fixed [ 1 ]
      Status Resolved [ 5 ] Reopened [ 4 ]
      Mark Miller added a comment -

      Hmm...I think the problem may be on core reload - for a time, there can be multiple update logs looking at the same directory.

      Mark Miller added a comment -

      nevermind, shouldn't be that - the updatehandler is shared across reloads...not seeing this one easily.

      Mark Miller added a comment -

      The test looks like it should be fine - so I'm still on the hunt for how something still refs the tlogs - I've tried over-closing everything with no luck. One option to work around it is to force a file system directory for this test, but it will just hide what looks like a bug.

      Uwe Schindler added a comment -

      I wonder why this can only be reproduced on Windows. If the test would use MockDirectory, the deleting of open files using FSDirectory.delete() should always fail (as far as I remember, Robert added such a check into MockDirectory).

      Mark Miller added a comment -

      tlog files are not actually worked with through a directory - they use a channel from a RAF.

      Mark Miller added a comment -

      Well I try and figure out what the issue is, I've made this log the error rather than throw an exception.

      Commit Tag Bot added a comment -

      [branch_4x commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1447312

      SOLR-4467: While looking into what looks like some kind of resource leak, make this hard fail a soft logging fail

      Commit Tag Bot added a comment -

      [trunk commit] Mark Robert Miller
      http://svn.apache.org/viewvc?view=revision&revision=1447308

      SOLR-4467: While looking into what looks like some kind of resource leak, make this hard fail a soft logging fail

      Robert Muir made changes -
      Fix Version/s 4.3 [ 12324128 ]
      Fix Version/s 5.0 [ 12321664 ]
      Fix Version/s 4.2 [ 12323893 ]
      Mark Miller added a comment -

      I think this may have been caused by SOLR-4604

      Uwe Schindler made changes -
      Fix Version/s 4.4 [ 12324324 ]
      Fix Version/s 4.3 [ 12324128 ]
      Steve Rowe added a comment -

      Bulk move 4.4 issues to 4.5 and 5.0

      Steve Rowe made changes -
      Fix Version/s 5.0 [ 12321664 ]
      Fix Version/s 4.5 [ 12324743 ]
      Fix Version/s 4.4 [ 12324324 ]
      Adrien Grand made changes -
      Fix Version/s 4.6 [ 12325000 ]
      Fix Version/s 5.0 [ 12321664 ]
      Fix Version/s 4.5 [ 12324743 ]
      Uwe Schindler made changes -
      Fix Version/s 4.7 [ 12325573 ]
      Fix Version/s 4.6 [ 12325000 ]
      David Smiley made changes -
      Fix Version/s 4.8 [ 12326254 ]
      Fix Version/s 4.7 [ 12325573 ]
      Uwe Schindler added a comment -

      Move issue to Solr 4.9.

      Uwe Schindler made changes -
      Fix Version/s 4.9 [ 12326731 ]
      Fix Version/s 5.0 [ 12321664 ]
      Fix Version/s 4.8 [ 12326254 ]

        People

        • Assignee:
          Mark Miller
          Reporter:
          Mark Miller
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:

            Development