Solr
  1. Solr
  2. SOLR-3903

Solrj library raises MissingFormatArgumentException when comitting update requests with parameters

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0-BETA
    • Fix Version/s: 4.0, 4.1, 6.0
    • Component/s: clients - java
    • Labels:
      None
    • Environment:

      Ubuntu 12.04, Solr 4.0.0-BETA running in a VirtualBox

      Description

      Observation

      • When the code pasted below is executed, a MissingFormatArgumentException is raised (Format specifier 's').
      • If setAction(..) is not called, no exception is thrown.

      Solution

      • Fixing the format call in ConcurrentUpdateSolrServer:164 might resolve the issue.

      Information

      • The issue is present in trunk.
      • I don't have the resources available to submit a proper patch at the moment, but might do so in the future. Meanwhile I'm posting this bug to let you know.
      ConcurrentUpdateSolrServer server = new ConcurrentUpdateSolrServer("http://localhost:8983/solr/collection1", 2, 2);
      UpdateRequest updateRequest = new UpdateRequest();
      SolrInputDocument document = new SolrInputDocument();
      updateRequest.add(document);
      updateRequest.setAction(UpdateRequest.ACTION.COMMIT, false, false);
      server.request(updateRequest);
      server.commit();
      

        Activity

        Hoss Man added a comment -

        thanks for reporting this ... the problem is that waitFlush was removed but it's still referenced in the format string used by this client.

        i'm going to try and get a fix for this into 4.0

        Hoss Man added a comment -

        the fix was trivial, but i spent over an hour trying ot figure out how to modify SolrExampleTests to reliably detect the failure in it's generic way before giving up and writing a one-off test for this.

        still doing some more exhaustive testing and then i'll commit and backport

        Hoss Man added a comment -

        Committed revision 1393794. - trunk
        Committed revision 1393801. - branch_4x
        Committed revision 1393804. - lucene_solr_4_0

        Commit Tag Bot added a comment -

        [branch_4x commit] Chris M. Hostetter
        http://svn.apache.org/viewvc?view=revision&revision=1393801

        SOLR-3903: Fixed MissingFormatArgumentException in ConcurrentUpdateSolrServer (merge r1393794 from trunk)


          People

          • Assignee:
            Hoss Man
            Reporter:
            Cedric Meury
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development