Solr
  1. Solr
  2. SOLR-3780

Maven builds regularly fail on ASF Jenkins

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0, 6.0
    • Fix Version/s: 4.0, 6.0
    • Component/s: Build
    • Labels:
      None

      Description

      branch_4x and to a lesser extent trunk Maven builds on ASF Jenkins regularly fail with these errors:

      ERROR: [doc=one] unknown field 'meta:creation-date'
      
      Stack Trace:
      org.apache.solr.common.SolrException: ERROR: [doc=one] unknown field 'meta:creation-date'
      	at __randomizedtesting.SeedInfo.seed([564B8C2811E551FC:388DF7271220FAA9]:0)
      	at org.apache.solr.update.DocumentBuilder.toDocument(DocumentBuilder.java:306)
      
      ERROR: [doc=1000] multiple values encountered for non multiValued field val_i: [10, 20]
      
      Stack Trace:
      org.apache.solr.common.SolrException: ERROR: [doc=1000] multiple values encountered for non multiValued field val_i: [10, 20]
      	at __randomizedtesting.SeedInfo.seed([41D9D56849179839:C03F5B703E48F805]:0)
      	at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:402)
      

      I can't reproduce these errors locally.

        Activity

        Steve Rowe added a comment -

        On the dev@l.a.o mailing list, Yonik wrote:

        "multiple values encountered for non multiValued field val_i: [10, 20]"

        This should be very deterministic (i.e. it should always fail if it
        were actually a non multiValued field).
        The *_i fields are multivalued according to schema.xml, so this
        exception should not happen (the version=1.0 in schema.xml means
        multiValued=true by default).

        Off of the top of my head, the only thing I can figure is that the
        maven based tests are somehow getting the wrong schema sometimes.
        Maybe if there's some different with how solr homes are set between
        ant and maven?

        Currently, under the Maven build, solr-core and solrj tests are run together under the solr-core module, because Maven can't handle the dependencies among solr-core, solr test-framework, and solrj. As a result, both solr-core and solrj resources are co-mingled. I think this is what's happening here: due to the apparently non-deterministic solr-home detection logic, in some environments, the "wrong" schema.xml file is used with some tests.

        Steve Rowe added a comment -

        This patch separates solrj testing under Maven so that it runs on its own, rather than with solr-core.

        In order to do this, solrj needs to include solr-core source as test source, and include all solr-core dependencies as test dependencies.

        All tests pass for me locally.

        Steve Rowe added a comment -

        I committed the patch making solrj run its own tests to branch_4x and trunk.

        ERROR: [doc=one] unknown field 'meta:creation-date'

        Robert Muir pointed out on dev@l.a.o that this is caused by branch_4x Maven Solr configuration depending on Tika 1.2, while the rest of branch_4x hasn't gotten the update yet (SOLR-3707). I reverted the branch_4x dependency to Tika 1.1, and branch_4x Maven just succeeded on ASF Jenkins.

        I also committed a change to all Solr contribs removing the now unnecessary inclusion of solr-core test resources in their test classpaths.

        Uwe Schindler added a comment -

        Closed after release.


          People

          • Assignee:
            Steve Rowe
            Reporter:
            Steve Rowe
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development