Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-3015

QParserPlugins can not be SolrCoreAware

    XMLWordPrintableJSON

    Details

      Description

      QParserPlugin cannot be made SolrCoreAware:

          [junit] org.apache.solr.common.SolrException: Invalid 'Aware' object: org.apache.solr.mcf.ManifoldCFQParserPlugin@18941f7 -- org.apache.solr.util.plugin.SolrCoreAware must be an instance of: [org.apache.solr.request.SolrRequestHandler]
      [org.apache.solr.response.QueryResponseWriter] [org.apache.solr.handler.component.SearchComponent] [org.apache.solr.update.processor.UpdateRequestProcessorFactory] [org.apache.solr.handler.component.ShardHandlerFactory]
      

        Attachments

        1. SOLR-3015.patch
          0.6 kB
          Karl Wright

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              kwright@metacarta.com Karl Wright
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: