Solr
  1. Solr
  2. SOLR-2755

StreamingUpdateSolrServer is hard-coded to write XML data. It should integrate the RequestWriter API so that it can be used to send binary update payloads.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 3.3
    • Fix Version/s: None
    • Component/s: clients - java
    • Labels:

      Description

      The aim of this patch is to use the RequestWriter API with StreamingUpdateSolrServer.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        219d 12h 49m 1 Sami Siren 19/Apr/12 06:19
        Patrick Sauts added a comment -

        Excellent news, thank you.

        Another thing was also when heavily accessed, I mean 60 threads sending docs to the StreamingUpdateSolrServer, I experienced hangs and even freeze with the StreamingUpdateSolrServer.
        That's why in our configuration I needed also a buffer before the BlockingQueue (wich appeared to be the cause of the problem).

        Sami Siren made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Sami Siren [ siren ]
        Fix Version/s 4.0 [ 12314992 ]
        Resolution Won't Fix [ 2 ]
        Sami Siren added a comment -

        StreamingUpdateSolrServer uses to not consider other parameters than the query itself.

        Parameters now work after SOLR-3139. I just added a test case for this and it seems all is good now.

        Patrick Sauts added a comment - - edited

        StreamingUpdateSolrServer uses to not consider other parameters than the query itself.
        Meaning that if you use a QT parameter (sharding as a plugin for example) , StreamingUpdateSolrServer didn't take it into account.
        Sorry I can't tell if it's still the case as I'm not currently working on Solr.

        Sami Siren added a comment -

        SOLR-1565 added support for javabin.

        Patrick: Is there something that this solution adds that was not part of SOLR-1565?

        Hoss Man made changes -
        Fix Version/s 3.6 [ 12319065 ]
        Hoss Man added a comment -

        Bulk changing fixVersion 3.6 to 4.0 for any open issues that are unassigned and have not been updated since March 19.

        Email spam suppressed for this bulk edit; search for hoss20120323nofix36 to identify all issues edited

        Simon Willnauer made changes -
        Fix Version/s 3.6 [ 12319065 ]
        Fix Version/s 3.5 [ 12317876 ]
        Shalin Shekhar Mangar added a comment -

        Patrick, I'm not sure that the amount of changes in this patch are necessary. Do you think that the patch I attached to SOLR-1565 will serve your purpose?

        Patrick Sauts added a comment -

        Patch done on 3.4 release.
        Bug fix : asynchronous insert into List<SolrDocument> could cause array out of bound exception

        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494872 ]
        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494079 ]
        Robert Muir made changes -
        Fix Version/s 3.5 [ 12317876 ]
        Fix Version/s 4.0 [ 12314992 ]
        Fix Version/s 3.4 [ 12316683 ]
        Robert Muir added a comment -

        3.4 -> 3.5

        Patrick Sauts added a comment -

        It is more a buffered asynchronous updater than a real streaming updater.

        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494079 ]
        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494076 ]
        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494076 ]
        Patrick Sauts made changes -
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494072 ]
        Patrick Sauts made changes -
        Field Original Value New Value
        Attachment patch-StreamingUpdateSolrServer.txt [ 12494072 ]
        Patrick Sauts created issue -

          People

          • Assignee:
            Sami Siren
            Reporter:
            Patrick Sauts
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development