Uploaded image for project: 'Solr'
  1. Solr
  2. SOLR-13750

[CVE-2019-12401] XML Bomb in Apache Solr versions prior to 5.0.0

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Information Provided
    • Affects Version/s: 1.3, 1.4, 1.4.1, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.6.1, 3.6.2, 4.0, 4.1, 4.2, 4.2.1, 4.3, 4.3.1, 4.4, 4.5, 4.5.1, 4.6, 4.6.1, 4.7, 4.7.1, 4.7.2, 4.8, 4.8.1, 4.9, 4.9.1, 4.10, 4.10.1, 4.10.2, 4.10.3, 4.10.4
    • Fix Version/s: 5.0
    • Component/s: None
    • Security Level: Public (Default Security Level. Issues are Public)
    • Labels:
      None

      Description

      Severity: Medium

      Vendor: The Apache Software Foundation

      Versions Affected:
      1.3.0 to 1.4.1
      3.1.0 to 3.6.2
      4.0.0 to 4.10.4

      Description:
      Solr versions prior to 5.0.0 are vulnerable to an XML resource consumption attack (a.k.a. Lol Bomb) via it’s update handler.
      By leveraging XML DOCTYPE and ENTITY type elements, the attacker can create a pattern that will expand when the server parses the XML causing OOMs.

      Mitigation:

      • Upgrade to Apache Solr 5.0 or later.
      • Ensure your network settings are configured so that only trusted traffic is allowed to post documents to the running Solr instances.

      Credit:
      Matei "Mal" Badanoiu

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              tflobbe Tomas Eduardo Fernandez Lobbe
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: