ServiceMix 4
  1. ServiceMix 4
  2. SMX4-749

JBI deployer version range is not up to date

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.0
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      The JBI deployer Import-Package version range is not correct. It still uses ServiceMix Components 2010.02 whereas we updated to 2011.01.

      > java.lang.Exception: Could not start bundle mvn:org.apache.servicemix.jbi/org.apache.servicemix.jbi.deployer/1.4.0-SNAPSHOT in feature(s) jbi-1.4.0-SNAPSHOT: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
      > at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:326)[19:org.apache.karaf.features.core:2.1.3]
      > at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:792)[19:org.apache.karaf.features.core:2.1.3]
      > Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.jbi.deployer [94]: Unable to resolve 94.0: missing requirement [94.0] package; (&(package=org.apache.servicemix.common.osgi)(version>=2010.2.0)(!(version>=2011.0.0)))
      > at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)[org.apache.felix.framework-3.0.2.jar:]
      > at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)[org.apache.felix.framework-3.0.2.jar:]
      > at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)[org.apache.felix.framework-3.0.2.jar:]
      > at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)[org.apache.felix.framework-3.0.2.jar:]
      > at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:323)[19:org.apache.karaf.features.core:2.1.3]
      > ... 1 more

        Activity

        Hide
        Freeman Fang added a comment -

        Hi JB,

        This problem is from that we need update the nmr/pom.xml servicemix-shared.version to latest 2011.01-SNAPSHOT for now.
        And my commit[1] already fix it.
        So if you rebuild nmr project then build features everything should be fine.
        [1]http://svn.apache.org/viewvc?rev=1060225&view=rev

        Best Regards
        Freeman

        Show
        Freeman Fang added a comment - Hi JB, This problem is from that we need update the nmr/pom.xml servicemix-shared.version to latest 2011.01-SNAPSHOT for now. And my commit [1] already fix it. So if you rebuild nmr project then build features everything should be fine. [1] http://svn.apache.org/viewvc?rev=1060225&view=rev Best Regards Freeman
        Show
        Freeman Fang added a comment - fixed by http://svn.apache.org/viewvc?rev=1060225&view=rev

          People

          • Assignee:
            Freeman Fang
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development