ServiceMix 4
  1. ServiceMix 4
  2. SMX4-735

Problem on install camel-cxf component for unresolved dependency org.apache.servicemix.specs/org.apache.servicemix.specs.jsr311-api_1.0/1.6.0

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: Bundles
    • Labels:
      None
    • Environment:

      Description

      Error on deploy camel-cxf component:
      10:30:55,559 | ERROR | l Console Thread | FeaturesServiceImpl | res.internal.FeaturesServiceImpl 556 | 12 - org.apache.karaf.features.core - 2.1.2 | URL [mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.jsr311-api_1.0/1.6.0] could not be resolved.
      10:30:55,589 | INFO | l Console Thread | Console | araf.shell.console.jline.Console 187 | 29 - org.apache.karaf.shell.console - 2.1.2 | Exception caught while executing command
      java.lang.RuntimeException: URL [mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.jsr311-api_1.0/1.6.0] could not be resolved.
      at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:195)[1:org.ops4j.pax.url.mvn:1.2.1]
      at org.ops4j.pax.url.mvn.internal.AetherBridgeConnection.getInputStream(AetherBridgeConnection.java:68)[1:org.ops4j.pax.url.mvn:1.2.1]
      at java.net.URL.openStream(URL.java:1010)[:1.6.0_22]
      at org.apache.karaf.features.internal.FeaturesServiceImpl.installBundleIfNeeded(FeaturesServiceImpl.java:554)[12:org.apache.karaf.features.core:2.1.2]
      at org.apache.karaf.features.internal.FeaturesServiceImpl.doInstallFeature(FeaturesServiceImpl.java:404)[12:org.apache.karaf.features.core:2.1.2]
      at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:249)[12:org.apache.karaf.features.core:2.1.2]
      at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:238)[12:org.apache.karaf.features.core:2.1.2]
      at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:234)[12:org.apache.karaf.features.core:2.1.2]
      at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:51)[18:org.apache.karaf.features.command:2.1.2]
      at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:39)[18:org.apache.karaf.features.command:2.1.2]
      at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.CommandProxy.execute(CommandProxy.java:50)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.Closure.execute(Closure.java:229)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.Closure.executeStatement(Closure.java:162)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.Pipe.run(Pipe.java:101)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.Closure.execute(Closure.java:79)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.felix.gogo.runtime.shell.CommandSessionImpl.execute(CommandSessionImpl.java:71)[29:org.apache.karaf.shell.console:2.1.2]
      at org.apache.karaf.shell.console.jline.Console.run(Console.java:169)[29:org.apache.karaf.shell.console:2.1.2]
      at java.lang.Thread.run(Thread.java:662)[:1.6.0_22]

        Activity

        Gert Vanthienen added a comment -

        @Claus: As soon as 4.3.0 has been released, we're planning to add a bit of OBR goodness to the way we handle features (cfr. https://issues.apache.org/jira/browse/SMX4-654) and that should allow us to just leverage the Camel-provided features.xml file to reduce the maintenance effort.

        Ge@@ru added a comment -

        Hi, i updated my trunk and i installed feature camel-cxf correctly. Problem is resolved.

        Thanks.
        Geaaru

        Freeman Fang added a comment -

        Hi Claus,

        Always for some reason the camel-features.xml from camel can't totally meet the requirement for smx release, it's mainly for the different bundle version conflict(the one used in camel and the one used in features) or there's something wrong with camel-features.xml shipped with camel. So we just maintain a camel-features.xml copy in smx4, we also do same thing for activemq-features.xml.

        SMX4-462[1] introduce camel-features.xml in smx4.
        SMX4-594[2] introduce activemq-features.xml in smx4
        they're both temporary workaround at that moment, but there might may other reasons(which I don't know) why we still keep it now

        Btw, JB upgrade to camel 2.5.0 and activemq 5.4.2 recently, maybe he know the details why still need maintain camel-features.xml and activemq-features.xml in smx4
        [1]https://issues.apache.org/jira/browse/SMX4-462
        [2]https://issues.apache.org/jira/browse/SMX4-594

        Best Regards
        Freeman

        Claus Ibsen added a comment -

        Freeman what's the purpose of this file?
        /servicemix/smx4/features/trunk/assembly/src/main/filtered-resources/camel-features.xml

        In the Camel project we do have features file for installing all the Camel components. So are we duplicating work here?
        https://svn.apache.org/repos/asf/camel/trunk/platforms/karaf/features/src/main/resources/features.xml

        Freeman Fang added a comment -

        this is caused by the artifact id should be
        org.apache.servicemix.specs.jsr311-api-1.0
        but not
        org.apache.servicemix.specs.jsr311-api_1.0

        Autually for camel-cxf should use
        org.apache.servicemix.specs.jsr311-api-1.1 but not 1.0.


          People

          • Assignee:
            Freeman Fang
            Reporter:
            Ge@@ru
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development