Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      Following the update to Karaf 2.1.0, the JRE package definition has changed.

      The features/NMR assembly should upgrade the configuration file as expected by Karaf 2.1.0.

        Activity

        Jean-Baptiste Onofré added a comment -

        More globally, I'm going to review the karaf configuration file to see the one which have to be override by ServiceMix.

        Jean-Baptiste Onofré added a comment -

        The problem is not in the Karaf jre.properties file directly.

        When starting SMX4 using Karaf 2.1.0, I got:

        ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.5.0, org.osgi.framework.launch; version=1.0.0, org.osgi.framework.hooks.service; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.4.0, org.apache.karaf.jaas.boot; version=2.1.0, org.apache.karaf.version; version=2.1.0, , com.sun.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp, com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap, javax.accessibility, # javax.activation, javax.activity, # javax.annotation, # javax.annotation.processing, javax.crypto, javax.crypto.interfaces, javax.crypto.spec, javax.imageio, javax.imageio.event, javax.imageio.metadata, javax.imageio.plugins.bmp, javax.imageio.plugins.jpeg, javax.imageio.spi, javax.imageio.stream, # javax.jws, # javax.jws.soap, javax.lang.model, javax.lang.model.element, javax.lang.model.type, javax.lang.model.util, javax.management, javax.management.loading, javax.management.modelmbean, javax.management.monitor, javax.management.openmbean, javax.management.relation, javax.management.remote, javax.management.remote.rmi, javax.management.timer, javax.naming, javax.naming.directory, javax.naming.event, javax.naming.ldap, javax.naming.spi, javax.net, javax.net.ssl, javax.print, javax.print.attribute, javax.print.attribute.standard, javax.print.event, javax.rmi, javax.rmi.CORBA, javax.rmi.ssl, javax.security.auth, javax.security.auth.callback, javax.security.auth.kerberos, javax.security.auth.login, javax.security.auth.spi, javax.security.auth.x500, javax.security.cert, javax.security.sasl, javax.sound.midi, javax.sound.midi.spi, javax.sound.sampled, javax.sound.sampled.spi, javax.sql, javax.sql.rowset, javax.sql.rowset.serial, javax.sql.rowset.spi, javax.swing, javax.swing.border, javax.swing.colorchooser, javax.swing.event, javax.swing.filechooser, javax.swing.plaf, javax.swing.plaf.basic, javax.swing.plaf.metal, javax.swing.plaf.multi, javax.swing.plaf.synth, javax.swing.table, javax.swing.text, javax.swing.text.html, javax.swing.text.html.parser, javax.swing.text.rtf, javax.swing.tree, javax.swing.undo, javax.tools, javax.transaction; javax.transaction.xa; partial=true; mandatory:=partial, javax.xml, # javax.xml.bind, # javax.xml.bind.annotation, # javax.xml.bind.annotation.adapters, # javax.xml.bind.attachment, # javax.xml.bind.helpers, # javax.xml.bind.util, javax.xml.crypto, javax.xml.crypto.dom, javax.xml.crypto.dsig, javax.xml.crypto.dsig.dom, javax.xml.crypto.dsig.keyinfo, javax.xml.crypto.dsig.spec, javax.xml.datatype, javax.xml.namespace, javax.xml.parsers, # javax.xml.soap, # javax.xml.stream, # javax.xml.stream.events, # javax.xml.stream.util, javax.xml.transform, javax.xml.transform.dom, javax.xml.transform.sax, javax.xml.transform.stax, javax.xml.transform.stream, javax.xml.validation, # javax.xml.ws, # javax.xml.ws.handler, # javax.xml.ws.handler.soap, # javax.xml.ws.http, # javax.xml.ws.soap, # javax.xml.ws.spi, javax.xml.xpath, org.ietf.jgss, org.omg.CORBA, org.omg.CORBA_2_3, org.omg.CORBA_2_3.portable, org.omg.CORBA.DynAnyPackage, org.omg.CORBA.ORBPackage, org.omg.CORBA.portable, org.omg.CORBA.TypeCodePackage, org.omg.CosNaming, org.omg.CosNaming.NamingContextExtPackage, org.omg.CosNaming.NamingContextPackage, org.omg.Dynamic, org.omg.DynamicAny, org.omg.DynamicAny.DynAnyFactoryPackage, org.omg.DynamicAny.DynAnyPackage, org.omg.IOP, org.omg.IOP.CodecFactoryPackage, org.omg.IOP.CodecPackage, org.omg.Messaging, org.omg.PortableInterceptor, org.omg.PortableInterceptor.ORBInitInfoPackage, org.omg.PortableServer, org.omg.PortableServer.CurrentPackage, org.omg.PortableServer.POAManagerPackage, org.omg.PortableServer.POAPackage, org.omg.PortableServer.portable, org.omg.PortableServer.ServantLocatorPackage, org.omg.SendingContext, org.omg.stub.java.rmi, org.omg.stub.javax.management.remote.rmi, org.w3c.dom, org.w3c.dom.bootstrap, org.w3c.dom.css, org.w3c.dom.events, org.w3c.dom.html, org.w3c.dom.ls, org.w3c.dom.ranges, org.w3c.dom.stylesheets, org.w3c.dom.traversal, org.w3c.dom.views, org.w3c.dom.xpath, org.xml.sax, org.xml.sax.ext, org.xml.sax.helpers,org.apache.karaf.branding; com.sun.org.apache.xalan.internal.xsltc.trax; com.sun.org.apache.xerces.internal.dom; com.sun.org.apache.xerces.internal.jaxp; com.sun.org.apache.xerces.internal.xni; com.sun.jndi.ldap (java.lang.IllegalArgumentException: No paths specified in header: )
        java.lang.IllegalArgumentException: No paths specified in header:
        at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeaderClause(ManifestParser.java:1429)
        at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeader(ManifestParser.java:1397)
        at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:162)
        at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:193)
        at org.apache.felix.framework.Felix.<init>(Felix.java:369)
        at org.apache.felix.framework.FrameworkFactory.newFramework(FrameworkFactory.java:28)
        at org.apache.karaf.main.Main.launch(Main.java:240)
        at org.apache.karaf.main.Main.main(Main.java:362)

        I suspect a not up to date configuration file in etc.

        I'm checking out Karaf 2.1.0 to see what is performed in Main (line 240).

        Jean-Baptiste Onofré added a comment -

        The issue is really in the etc/jre.properties file. If I use the karaf default one, it works.

        Jean-Baptiste Onofré added a comment -

        The issue was just the starting ',' :

        jre-1.5=, \
        [...]

        jre-1.6=, \
        [..]

        In Karaf 2.1.0, this starting ',' prevents the JRE package loading.

        Fixed in revision 1022284.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development