ServiceMix 4
  1. ServiceMix 4
  2. SMX4-564

stacktrace dumped on console when shutdown smx

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      when shutdown servicemix will get dumpStack on console like
      karaf@root> shutdown
      karaf@root> HasFaile=true on :java.io.EOFException
      java.lang.Exception: Stack trace
      at java.lang.Thread.dumpStack(Thread.java:1230)
      at org.apache.activemq.pool.ConnectionPool$1.onException(ConnectionPool.java:64)
      at org.apache.activemq.ActiveMQConnection$5.run(ActiveMQConnection.java:1863)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:637)
      HasFaile=true on :java.io.EOFException
      java.lang.Exception: Stack trace
      at java.lang.Thread.dumpStack(Thread.java:1230)
      at org.apache.activemq.pool.ConnectionPool$1.onException(ConnectionPool.java:64)
      at org.apache.activemq.ActiveMQConnection$5.run(ActiveMQConnection.java:1863)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:637)
      HasFaile=true on :java.io.EOFException
      java.lang.Exception: Stack trace
      at java.lang.Thread.dumpStack(Thread.java:1230)
      at org.apache.activemq.pool.ConnectionPool$1.onException(ConnectionPool.java:64)
      at org.apache.activemq.ActiveMQConnection$5.run(ActiveMQConnection.java:1863)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:637)

        Activity

        Freeman Fang added a comment -

        This is from activemq ./activemq-pool/src/main/java/org/apache/activemq/pool/ConnectionPool.java
        // Add a transport Listener so that we can notice if this connection
        // should be expired due to
        // a connection failure.
        connection.addTransportListener(new TransportListener() {
        public void onCommand(Object command) {
        }

        public void onException(IOException error) {
        synchronized (ConnectionPool.this)

        { System.err.println("HasFaile=true on :" + error); Thread.dumpStack(); hasFailed = true; }

        }

        and get introduced since activemq 5.4-SNAPSHOT.

        I think if we can't avoid jms connection failure on smx side when shutdown smx, then we need patch activemq, probably just put
        System.err.println("HasFaile=true on :" + error);
        Thread.dumpStack();
        to log, but not print out the stacktrace on console.

        Freeman Fang added a comment -

        confirmed this issue get fixed by commit
        http://svn.apache.org/viewvc?rev=985871&view=rev
        on activemq trunk


          People

          • Assignee:
            Freeman Fang
            Reporter:
            Freeman Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development