Uploaded image for project: 'ServiceMix 4'
  1. ServiceMix 4
  2. SMX4-548

remove javax.script package from config.properties for jre export package

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.0
    • Component/s: None
    • Labels:
      None

      Description

      we should use the one from Apache ServiceMix Specs :: Scripting API 1.0 .

      When run smx4 with felix 3.0.1, will see error like
      RE: org.apache.felix.framework.resolver.ResolveException: Constraint violation for package 'javax.script' when resolving module 178.0 between existing import 170.0.javax.script BLAMED ON [[178.0] package; (package=javax.script)] and uses constraint 0.javax.script BLAMED ON [[178.0] package; (package=com.google.code.scriptengines.groovy), [175.0] package; (package=javax.script)]

      This will fix it.

        Attachments

          Activity

            People

            • Assignee:
              ffang Freeman Fang
              Reporter:
              ffang Freeman Fang
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: