Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Bundles
    • Labels:
      None
    • Environment:

      ServiceMix 4.x, FUSE 4.2.x

      Description

      Rss polling endpoints can not be started in OSGi due NoClassDefError in ROME. Root cause of all problems are com.sun.syndication.io.impl.PropertiesLoader and Thread.currentThread().getContextClassLoader() usage in this class.
      Patch provided in http://repository.code-house.org/content/repositories/code-house.public.release/rome/rome/1.0-osgi/ may break rome features like providing own Parsers/Generators/Converters using rome.properties file.

      1. rome-bundle.patch
        10 kB
        Łukasz Dywicki
      2. patch.patch
        1 kB
        Łukasz Dywicki

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        4d 21h 22m 1 Łukasz Dywicki 24/Mar/10 09:15
        In Progress In Progress Open Open
        2h 3m 1 Łukasz Dywicki 24/Mar/10 11:19
        Open Open Resolved Resolved
        2d 22m 1 Jean-Baptiste Onofré 26/Mar/10 11:41
        Glen Mazza added a comment -

        For archive notes, Lukasz' ROME JIRA for this is here: https://rometools.jira.com/browse/ROME-142

        Jeff Turner made changes -
        Project Import Sat Nov 27 01:13:56 EST 2010 [ 1290838436878 ]
        Willem Jiang made changes -
        Link This issue is related to SMX4-573 [ SMX4-573 ]
        Jean-Baptiste Onofré made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Jean-Baptiste Onofré added a comment -

        Revision 927781.

        Jean-Baptiste Onofré made changes -
        Assignee Łukasz Dywicki [ splatch ] Jean-Baptiste Onofré [ jb@nanthrax.net ]
        Łukasz Dywicki made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Łukasz Dywicki made changes -
        Attachment rome-bundle.patch [ 19080 ]
        Łukasz Dywicki added a comment -

        ServiceMix ROME bundle with fixed PluginManager.

        Willem Jiang added a comment -

        +1 for option 2, as we can get full control of it

        Łukasz Dywicki made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Łukasz Dywicki made changes -
        Assignee Gert Vanthienen [ gertvanthienen ] Łukasz Dywicki [ splatch ]
        Gert Vanthienen made changes -
        Summary Camel-rss don't work in OSGi Build ServiceMix bundle for Rome
        Gert Vanthienen made changes -
        Issue Type Bug [ 1 ] Task [ 3 ]
        Affects Version/s 2.2.0 [ 12170 ]
        Component/s camel-rss [ 11773 ]
        Key CAMEL-2562 SMX4-510
        Component/s Bundles [ 11870 ]
        Project Apache Camel [ 11020 ] ServiceMix 4 [ 11060 ]
        Łukasz Dywicki added a comment -

        I vote for second option. Putting another repository to Karaf with only one artifact is mistake.

        Gert Vanthienen added a comment -

        L.S.,

        If the patch provided fixes the issue, it's OK for me. We have two ways to get this included in Camel:

        1. use the version provided in repository.code-house.org which already includes the fix
        2. build a servicemix bundle for Rome which includes this fix

        Personally, I would prefer option 2 because that will eventually get us a valid bundle for Rome in central repository. If that's OK for everyone, I'll move the issue to the SMX4 project and build the bundle to update the Camel features.xml afterwards. If we stick to scenario 1, all we need to do in Camel is use that bundle in our features.xml and we're done.

        Regards,

        Gert

        Willem Jiang added a comment -

        Hi Lukasz,

        I'm afraid you need to create a JIRA in ServiceMix,which may ring the bell of Gert
        The only thing that I think we can do in Camel is updating the features file for new ROME bundle.

        Łukasz Dywicki added a comment -

        Hello Willem,
        You're right - this path is for ROME not for Camel. I subitted this here because ROME looks like death project (spam on developer mailing list, no activity on issue tracker). If patch will be accepted we can fix and move ROME codebase to servicemix bundles repository.

        Willem Jiang added a comment -

        @Lukasz,
        I don't think this patch is related to camel source repository.
        Did I missing something?

        Łukasz Dywicki made changes -
        Assignee Łukasz Dywicki [ splatch ] Gert Vanthienen [ gertvanthienen ]
        Łukasz Dywicki added a comment -

        Gert please review this simple patch. ROME team currently didn't say anything about issue submitted in last week.

        Łukasz Dywicki made changes -
        Field Original Value New Value
        Attachment patch.patch [ 19070 ]
        Łukasz Dywicki added a comment -

        Patch to review.

        Łukasz Dywicki added a comment -

        I checked this problem - ROME PluginManager try to use class loader from endpoint bundle. I added simple fallback condition to ROME - first of all ROME try to use bundle class loader to resolve plugin classes. If they will thow ClassNotFoundException PluginManager will use local class loader. All ROME features should work with this because patch does not have any impact to standard behaviour.

        Łukasz Dywicki created issue -

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Łukasz Dywicki
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development