ServiceMix
  1. ServiceMix
  2. SM-2265

Remove unnecessary external repositories

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.0
    • Fix Version/s: 5.0.0
    • Component/s: assemblies
    • Labels:
      None

      Description

      We currently define 5 external repositories in the root POM for ServiceMix 5. At first glance, at least a few of them are no longer necessary or relevant, so we should remove them.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 11h 47m 1 Gert Vanthienen 14/Mar/14 08:37
        Resolved Resolved Closed Closed
        382d 8h 50m 1 Krzysztof Sobkowiak 31/Mar/15 18:27
        Krzysztof Sobkowiak made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Cristiano Costantini added a comment -

        At revision 1578357 on tag http://svn.apache.org/repos/asf/servicemix/smx5/tags/servicemix-5.0.0,

        I've been able to build Servicemix with only Maven Central Repo and the following artifacts:
        org.activiti/activiti-camel/5.10 => https://maven.alfresco.com/nexus/content/groups/public/
        org.activiti/activiti-engine/5.10 => https://maven.alfresco.com/nexus/content/groups/public/
        org.activiti/activiti-osgi/5.10 => https://maven.alfresco.com/nexus/content/groups/public/
        org.activiti/activiti-root/5.10 => https://maven.alfresco.com/nexus/content/groups/public/
        org.activiti/activiti-spring/5.10 => https://maven.alfresco.com/nexus/content/groups/public/
        org.eclipse/osgi/3.8.0.v20120529-1548 => http://svn.apache.org/repos/asf/servicemix/m2-repo/
        everything else => maven central

        maybe the above artifacts could be released to Maven Central Repo too and get rid of external repositories?

        Gert Vanthienen added a comment -

        We really need to get rid of the remaining repository definitions - just spent some time troubleshooting a dependency resolution issue on the machine I was using for building the release. The problem was caused by this POM, which looks nothing like the "real thing":
        https://nexus.alfresco.com/nexus/content/groups/public/org/apache/felix/org.apache.felix.gogo.runtime/0.10.0/org.apache.felix.gogo.runtime-0.10.0.pom

        Gert Vanthienen made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Gert Vanthienen [ gertvanthienen ]
        Resolution Fixed [ 1 ]
        Gert Vanthienen added a comment -

        Fixed in http://svn.apache.org/viewvc?view=revision&revision=1577446

        At the moment, the only external repository that we're depending on is the Activiti/Alfresco one - this one can be removed as soon as SM-2229 gets resolved.

        I did push the repository definition down from the root POM into the modules that really require it in order to limit its impact.

        Gert Vanthienen created issue -

          People

          • Assignee:
            Gert Vanthienen
            Reporter:
            Gert Vanthienen
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development