Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0.0
    • Component/s: examples
    • Labels:
      None

      Description

      Now that we recommend people to not start using JBI anymore, we should ensure that we have documentation and examples that show how to replace commonly used JBI components, e.g. servicemix-wsn2005.

      We should add an example that shows how to use CXF's WSN support in the ServiceMix CXF example set.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        324d 11h 1 Freeman Fang 08/May/13 09:17
        In Progress In Progress Resolved Resolved
        1d 19h 32m 1 Freeman Fang 10/May/13 04:49
        Resolved Resolved Closed Closed
        690d 13h 37m 1 Krzysztof Sobkowiak 31/Mar/15 18:27
        Krzysztof Sobkowiak made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Freeman Fang added a comment -

        Hi Wim,

        Patch applied, thanks,

        Freeman

        Wim Verreydt added a comment - - edited

        When I tested the example, i had a "Caused by: javax.jms.JMSException: User name [user] or password is invalid." exception. I think this is due to the JAAS authentication wich seemed to be enabled by default in AMQ (http://search.maven.org/remotecontent?filepath=org/apache/activemq/activemq-karaf/5.8.0/activemq-karaf-5.8.0-activemq.xml). The problem is fixed when I add the config file with the username and password so i made a pull request to add these instructions back to the readme file.

        The pull request can be found here: https://github.com/apache/servicemix5/pull/6

        Freeman Fang made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Freeman Fang added a comment -

        apply patch on behalf of Wim Verreydt with thanks
        http://svn.apache.org/r1480872

        Very nice example btw. Only revise the README.txt a little bit, as in Apache Servicemix kit, the default AMQ broker won't enable JAAS authentication, so we needn't configure cxf-wsn to specify the user/password to connect to the broker.

        Freeman Fang made changes -
        Project ServiceMix 4 [ 12311208 ] ServiceMix [ 12311206 ]
        Key SMX4-1189 SM-2199
        Affects Version/s 4.4.2 [ 12321271 ]
        Fix Version/s 5.0.0 [ 12324078 ]
        Fix Version/s 4.6.0 [ 12321272 ]
        Component/s examples [ 12320393 ]
        Component/s Examples [ 12314204 ]
        Freeman Fang made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Freeman Fang made changes -
        Assignee Freeman Fang [ ffang ]
        Wim Verreydt added a comment -

        I'll take a stab at this one.

        Gert Vanthienen made changes -
        Field Original Value New Value
        Fix Version/s 4.6.0 [ 12321272 ]
        Fix Version/s 4.5.0 [ 12319159 ]
        Gert Vanthienen created issue -

          People

          • Assignee:
            Freeman Fang
            Reporter:
            Gert Vanthienen
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development