Uploaded image for project: 'ServiceMix'
  1. ServiceMix
  2. SM-1972

Missing javax.annotation causes exceptions on AIX

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.3.2
    • Fix Version/s: 3.4.0
    • Component/s: None
    • Labels:
      None

      Description

      When running the build on AIX, you run into the below exception for the bridge integration tests:

      org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.apache.activemq.xbean.XBeanBrokerService#0' 
      defined in class path resource [integrationTest.xml]: Initialization of bean failed;
      nested exception is java.lang.TypeNotPresentException: Type javax.annotation.PostConstruct not present
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:527)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456)
      ... 
      Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct
      at java.lang.Class.forNameImpl(Native Method)
      at java.lang.Class.forName(Class.java:163)
      at com.ibm.oti.reflect.AnnotationHelper.getAnnotation(AnnotationHelper.java:33)
      ... 45 more
      

      For the IBM JDK, these annotations should be present even if they're not actually used.

        Activity


          People

          • Assignee:
            gertvanthienen Gert Vanthienen
            Reporter:
            gertvanthienen Gert Vanthienen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development