Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-8301

Support servlet containers with servlet api 4.0

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Launchpad Base 2.6.36
    • Component/s: Launchpad
    • Labels:
      None

      Description

      With a webapp deployment, if a servlet container provides servlet api 4.0, then launchpad will "export" servlet api 2.6 and 4.0 to the OSGi environment, but not 3.1. Bundles importing a servlet api in the 3.x do not resolve in this case

        Attachments

          Activity

            People

            • Assignee:
              cziegeler Carsten Ziegeler
              Reporter:
              cziegeler Carsten Ziegeler
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: