Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-8178

Unable to resolve org.apache.sling.resourceresolver due to missing EventHandler

    XMLWordPrintableJSON

    Details

      Description

      2018-12-15T17:08:37,254 | ERROR | activator-1-thread-2 | BootFeaturesInstaller            | 11 - org.apache.karaf.features.core - 4.2.1 | Error installing boot features
      org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=sling; type=karaf.feature; version="[0.1.1.SNAPSHOT,0.1.1.SNAPSHOT]"; filter:="(&(osgi.identity=sling)(type=karaf.feature)(version>=0.1.1.SNAPSHOT)(version<=0.1.1.SNAPSHOT))" [caused by: Unable to resolve sling/0.1.1.SNAPSHOT: missing requirement [sling/0.1.1.SNAPSHOT] osgi.identity; osgi.identity=org.apache.sling.resourceresolver; type=osgi.bundle; version="[1.6.8,1.6.8]"; resolution:=mandatory [caused by: Unable to resolve org.apache.sling.resourceresolver/1.6.8: missing requirement [org.apache.sling.resourceresolver/1.6.8] osgi.service; filter:="(objectClass=org.osgi.service.event.EventHandler)"; effective:=active; cardinality:=multiple]]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332) ~[?:?]
      	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257) ~[?:?]
      	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964) ~[?:?]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
      	at java.lang.Thread.run(Thread.java:748) [?:?]
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve sling/0.1.1.SNAPSHOT: missing requirement [sling/0.1.1.SNAPSHOT] osgi.identity; osgi.identity=org.apache.sling.resourceresolver; type=osgi.bundle; version="[1.6.8,1.6.8]"; resolution:=mandatory [caused by: Unable to resolve org.apache.sling.resourceresolver/1.6.8: missing requirement [org.apache.sling.resourceresolver/1.6.8] osgi.service; filter:="(objectClass=org.osgi.service.event.EventHandler)"; effective:=active; cardinality:=multiple]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	... 12 more
      Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve org.apache.sling.resourceresolver/1.6.8: missing requirement [org.apache.sling.resourceresolver/1.6.8] osgi.service; filter:="(objectClass=org.osgi.service.event.EventHandler)"; effective:=active; cardinality:=multiple
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343) ~[?:?]
      	... 12 more
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                olli Oliver Lietz
                Reporter:
                olli Oliver Lietz
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: