Uploaded image for project: 'Sling'
  1. Sling
  2. SLING-7505

Installer: Set error message also for overwritten resources

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Installer Core 3.9.0
    • Component/s: Installer
    • Labels:
      None

      Description

      In case the OSGi installer gets a resource with the same entity id as an existing one but a lower version/priority/digest it remains in status "INSTALL". To improve the readability in the OSGi Installer web console, that state should be accompanied by an according error message (to make it clearer why this is not considered).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kwin Konrad Windszus
                Reporter:
                kwin Konrad Windszus
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: