Uploaded image for project: 'Shiro'
  1. Shiro
  2. SHIRO-516

Explicitly specify the version of aspectjtools to avoid build warning

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.2.3
    • Fix Version/s: 1.2.5
    • Component/s: None
    • Labels:

      Description

      When building the shiro-aspectj module there is a warning logged:

      [WARNING] bad version number found in /home/andreas/project-4.3/shiro/repository/org/aspectj/aspectjrt/1.6.12/aspectjrt-1.6.12.jar expected 1.6.11 found 1.6.12
      

      This warning is caused by a difference in versions used by the plugin and the version used by shiro, and as per http://jira.codehaus.org/browse/MASPECTJ-106 can and should be fixed by explicitly adding a dependency on the correct aspectjtools version for the plugin.

      See attached patch.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ankon Andreas Kohn
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: