Uploaded image for project: 'Shiro'
  1. Shiro
  2. SHIRO-278

Rename JndiLdapRealm to DefaultLdapRealm

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.3.0
    • Component/s: Realms
    • Labels:
      None

      Description

      the existing name 'JndiLdapRealm' (which should be our default widely-used implementation) was chosen because it uses the JNDI API as an LDAP API. End-users have explained that they overlooked the class because they thought it implied that they needed to be using JNDI (e.g. in an app server) in order to use it.

      Because of this confusion, the name should be changed to 'DefaultLdapRealm' to indicate it is our default/common implementation.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              lhazlewood Les Hazlewood

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment