Uploaded image for project: 'Sentry'
  1. Sentry
  2. SENTRY-461

Fix an issue of schema upgrade script

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      There is a typo issue in sentry-provider/sentry-provider-db/src/main/resources/sentry-upgrade-postgres-1.4.0-to-1.5.0.sql

      SELECT 'Upgrading Sentry store schema from 1.4.0 to 1.5.0';
      \i 001-SENTRY-339.postgres.sql;
      \i 002-SENTRY-339.postgres.sql;
      UPDATE SENTRY_VERSION SET SCHEMA_VERSION='1.5.0', VERSION_COMMENT='Sentry release version 1.5.0' WHERE VER_ID=1;
      SELECT 'Finished upgrading Sentry store schema from 1.4.0 to 1.5.0';                                                                  
      

      001-SENTRY-339.postgres.sql should be 001-SENTRY-327.postgres.sql

        Attachments

        1. SENTRY-461.patch
          0.8 kB
          Dapeng Sun

          Issue Links

            Activity

              People

              • Assignee:
                dapengsun Dapeng Sun
                Reporter:
                dapengsun Dapeng Sun
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: