Uploaded image for project: 'Sentry'
  1. Sentry
  2. SENTRY-1229

Add caching to SentryGenericProviderBackend

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8.0
    • Component/s: None
    • Labels:
      None

      Description

      Add a basic configurable cache to SentryGenericServiceClientDefaultImpl.

      1. SENTRY-1229.001.patch
        29 kB
        Ashish Singh
      2. SENTRY-1229.002.patch
        28 kB
        Ashish Singh
      3. SENTRY-1229.003.patch
        25 kB
        Ashish Singh
      4. SENTRY-1229.004.patch
        39 kB
        Ashish Singh
      5. SENTRY-1229.006.patch
        37 kB
        Ashish Singh
      6. SENTRY-1229.013.patch
        37 kB
        Ashish Singh

        Issue Links

          Activity

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12801829/SENTRY-1229.001.patch against master.

          Overall: -1 due to an error

          ERROR: mvn test exited 1

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1516/console

          This message is automatically generated.

          singhashish Ashish Singh added a comment -

          Dapeng Sun mind reviewing this?

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12802535/SENTRY-1229.002.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1528/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12802703/SENTRY-1229.003.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1532/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12802860/SENTRY-1229.004.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1536/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12802861/SENTRY-1229.004.patch against master.

          Overall: -1 due to 2 errors

          ERROR: mvn test exited 1
          ERROR: Failed: org.apache.sentry.tests.e2e.dbprovider.TestDbPrivilegesAtFunctionScope

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1537/console

          This message is automatically generated.

          singhashish Ashish Singh added a comment -

          Test failure is unrelated, below is the test failure cause.

          java.io.FileNotFoundException: /tmp/1462674958180-0/etc/sentry-provider.ini (No such file or directory)
          	at org.apache.sentry.tests.e2e.dbprovider.TestDbPrivilegesAtFunctionScope.setupTestStaticConfiguration(TestDbPrivilegesAtFunctionScope.java:35)
          
          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12803607/SENTRY-1229.006.patch against master.

          Overall: -1 due to an error

          ERROR: failed to apply patch (exit code 1):
          The patch does not appear to apply with p0, p1, or p2

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1548/console

          This message is automatically generated.

          colinma Colin Ma added a comment -

          Ashish Singh, please rebase the patch, thanks.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12803884/SENTRY-1229.011.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1552/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12803942/SENTRY-1229.012.patch against master.

          Overall: -1 due to 3 errors

          ERROR: mvn test exited 1
          ERROR: Failed: org.apache.sentry.tests.e2e.dbprovider.TestDbConnections
          ERROR: Failed: org.apache.sentry.tests.e2e.dbprovider.TestDbConnections

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1553/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12804070/SENTRY-1229.013.patch against master.

          Overall: -1 due to an error

          ERROR: failed to build with patch (exit code 1)

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1554/console

          This message is automatically generated.

          singhashish Ashish Singh added a comment -

          The build failed due to http://repo.maven.apache.org/maven2/org/restlet/jee/org.restlet.ext.servlet/2.1.1/org.restlet.ext.servlet-2.1.1.pom being unavailable. Apache repository have been unavailable for past 2 days now .

          singhashish Ashish Singh added a comment -

          Built locally with -o and it built fine.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12804089/SENTRY-1229.013.patch against master.

          Overall: -1 due to 2 errors

          ERROR: mvn test exited 1
          ERROR: Failed: org.apache.sentry.provider.db.generic.service.persistent.TestPrivilegeOperatePersistence

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1556/console

          This message is automatically generated.

          colinma Colin Ma added a comment -

          +1 for the current patch, pending on pre-commit.
          Ashish Singh, I'll do the rebuild for this patch if the failed is not caused by patch.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12804089/SENTRY-1229.013.patch against master.

          Overall: -1 due to 2 errors

          ERROR: mvn test exited 1
          ERROR: Failed: org.apache.sentry.provider.db.service.thrift.TestSentryWebServerWithSSL

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1558/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12804089/SENTRY-1229.013.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1555/console

          This message is automatically generated.

          hadoopqa Hadoop QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12804089/SENTRY-1229.013.patch against master.

          Overall: +1 all checks pass

          SUCCESS: all tests passed

          Console output: https://builds.apache.org/job/PreCommit-SENTRY-Build/1557/console

          This message is automatically generated.


            People

            • Assignee:
              singhashish Ashish Singh
              Reporter:
              singhashish Ashish Singh
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development