Uploaded image for project: 'Commons Sandbox'
  1. Commons Sandbox
  2. SANDBOX-395

Correct names for classes and variables related to operations on weights

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Graph

      Description

      Hi all,

      as discussed in ML already the current classes/variables that refer to operations on weights can be renamed for better expressiveness:

      • all the classes under weight.primitive should be renamed from XXX to XXXOperations because they actually contain operations on weights (they do not represent weights themselves);
      • in the actual algorithms, all variable names for weight operations should actually be something like weightOperations instead of the name of the interface (e.g. orderedMonoid).

        Attachments

          Activity

            People

            • Assignee:
              claudio.squarcella Claudio Squarcella
              Reporter:
              claudio.squarcella Claudio Squarcella

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment