Uploaded image for project: 'Rya'
  1. Rya
  2. RYA-324

geoWave and geoMesa depend on different versions of the GeoTools

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Patch, Important

    Description

      Refactored geo libraries into separate projects/modules/jars.
      Geo libraries are optional and turned off by default because the GeoTools is has an incompatible license.
      Further, geoWave and geoMesa depend on different versions of the GeoTools, so they must be in separate projects.
      The new modules (projects) are
      geo.common
      geo.mongo
      geo.geomesa
      geo.geowave

      These are modules of the project rya.geoindexing

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            dlotts David Lotts
            dlotts David Lotts
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment