Uploaded image for project: 'Apache Roller'
  1. Apache Roller
  2. ROL-2104

issue upgrading from version 2.3 to 5.1

    XMLWordPrintableJSON

    Details

    • Database:
      Oracle 12.1.0.2
    • O/S Version:
      Oracle Linux 7

      Description

      Hello,

      I have been attempting to upgrade our Roller version from 2.3 to the latest version 5.1.2. Whilst doing this upgrade I am also attempting to migrate Roller from an old server to a new one running Apache Tomcat 7.

      I have ran through the migration scripts to cover every iteration from 2.3 to 5.1.2 (and edited the code contained in some of the scripts for them to work) however I am now stuck with a couple of issues that is delaying the project.

      The current situation is:

      I have Roller running on Apache Tomcat V7 and have logged into the administration console;
      My users have migrated correctly and the application is talking successfully to the Oracle 12c database;
      The custom themes that we use on 2.3 are .css based, where as it looks like now they should be .xml. - is there any guidance on how to convert these themes to the new standard?
      I am able to create a new posting successfully, however I am unable to view these postings due to a 404 error where by it looks like the app is unable to find/display the page. Do you have any suggestions on what could be the issue there?

      Any assistance would be very gratefully received!

        Attachments

          Activity

            People

            • Assignee:
              roller_unassigned Roller Unassigned
              Reporter:
              reed_dba reed_dba
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: