Uploaded image for project: 'Apache RocketMQ'
  1. Apache RocketMQ
  2. ROCKETMQ-318

Remoting Connection Exception - Connect to server failed

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Critical
    • Resolution: Unresolved
    • 4.0.0-incubating, 4.1.0-incubating
    • None
    • None
    • macOS Sierra (10.12.3)

    Description

      I setup RocketMQ (4.1.0-incubating-release) and started it's nameserver and broker as per this instruction on Quick Start. Nameserver and broker started up well. However I can't create a new topic or see topic list or see a status of any topic. I get the following error.

      $ sh bin/mqadmin updateTopic -n localhost:9876 -c DefaultCluster -r 2 -w 2 -t MY_TOPIC
      
      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
      
      org.apache.rocketmq.remoting.exception.RemotingConnectException: connect to **<[fe80:-2>** failed
          at org.apache.rocketmoi.remoting.netty.NettyRemotingClient.invokeSync(NettyRemotingClient.java:357)
          at org.apache.rocketmq.client.impl.MQClientAPIImpl.createTopic(MQClientAPIImpl.java:266)
          at org.apache.rocketmq.tools.admin.DefaultMQAdminExtImpl.createAndUpdateTopicConfig(DefaultMQAdminExtImpl.java:176)
          at org.apache.rocketmq.tools.admin.DefaultMQAdminExt.createAndUpdateTopicConfig(DefaultMQAdminExt.java:156)
          at org.apache.rocketmq.tools.command.topic.UpdateTopicSubCommand.execute(UpdateTopicSubCommand.java:154)
          at org.apache.rocketmq.tools.command.MQAdminStartup.mainO(MQAdminStartup.java:128)
          at org.apache.rocketmq.tools.command.MQAdminStartup.main(MQAdminStartup.java:78)
      

      I tried both compiling the source myself and downloaded the compiled binary from Apache's site. I also tried 4.0.0-incubating-release binary. It allowed to me to list the topics using sh mqadmin topicList. But it didn't allow me to create a new topic owing to the above exception.

      I don't see any relevant log in any of the rocketmq logs (namesrv.log, broker.log or remoting.log).

      UPDATE:
      It worked for sometime and now it's not working again.

      Attachments

        Activity

          People

            vintagewang Xiaorui Wang
            rajbdilip Dilip Raj Baral
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: